blob: 169bd6206bed97926aa8ec786609c965dcfbb164 [file] [log] [blame]
Andrew Geisslerd25ed322020-06-27 00:28:28 -05001SUMMARY = "A multi-platform support library with a focus on asynchronous I/O"
2HOMEPAGE = "https://github.com/libuv/libuv"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06003DESCRIPTION = "libuv is a multi-platform support library with a focus on asynchronous I/O. It was primarily developed for use by Node.js, but it's also used by Luvit, Julia, pyuv, and others."
Andrew Geisslerd25ed322020-06-27 00:28:28 -05004BUGTRACKER = "https://github.com/libuv/libuv/issues"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=a68902a430e32200263d182d44924d47"
7
Patrick Williams213cb262021-08-07 19:21:33 -05008SRCREV = "6ce14710da7079eb248868171f6343bc409ea3a4"
Andrew Geisslerd25ed322020-06-27 00:28:28 -05009SRC_URI = "git://github.com/libuv/libuv;branch=v1.x"
10
11S = "${WORKDIR}/git"
12
13inherit autotools
14
15do_configure() {
16 ${S}/autogen.sh || bbnote "${PN} failed to autogen.sh"
17 oe_runconf
18}
19
20BBCLASSEXTEND = "native"