blob: 83e3fddccc1b367af6052c5a28f38a4d01111c53 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001require recipes-core/meta/buildtools-tarball.bb
2
3DESCRIPTION = "SDK type target for building a standalone tarball containing build-essentials, python3, chrpath, \
4 make, git and tar. The tarball can be used to run bitbake builds on systems which don't meet the \
5 usual version requirements and have ancient compilers."
6SUMMARY = "Standalone tarball for running builds on systems with inadequate software and ancient compilers"
7LICENSE = "MIT"
8
9# Add nativesdk equivalent of build-essentials
10TOOLCHAIN_HOST_TASK += "\
11 nativesdk-automake \
12 nativesdk-autoconf \
13 nativesdk-binutils \
14 nativesdk-binutils-symlinks \
15 nativesdk-cpp \
16 nativesdk-cpp-symlinks \
17 nativesdk-gcc \
18 nativesdk-gcc-symlinks \
19 nativesdk-g++ \
20 nativesdk-g++-symlinks \
21 nativesdk-gettext \
22 nativesdk-libatomic \
23 nativesdk-libgcc \
24 nativesdk-libgomp-dev \
25 nativesdk-libstdc++ \
26 nativesdk-libstdc++-dev \
27 nativesdk-libstdc++-staticdev \
28 nativesdk-libtool \
29 nativesdk-pkgconfig \
30 nativesdk-glibc-utils \
Andrew Geissler9b4d8b02021-02-19 12:26:16 -060031 nativesdk-glibc-gconv-ibm850 \
32 nativesdk-glibc-gconv-iso8859-1 \
33 nativesdk-glibc-gconv-utf-16 \
34 nativesdk-glibc-gconv-cp1250 \
35 nativesdk-glibc-gconv-cp1251 \
36 nativesdk-glibc-gconv-cp1252 \
37 nativesdk-glibc-gconv-euc-jp \
38 nativesdk-glibc-gconv-libjis \
Andrew Geissler82c905d2020-04-13 13:39:40 -050039 nativesdk-libxcrypt-dev \
Andrew Geissler09209ee2020-12-13 08:44:15 -060040 nativesdk-parted \
41 nativesdk-dosfstools \
42 nativesdk-gptfdisk \
Andrew Geissler82c905d2020-04-13 13:39:40 -050043 "
Andrew Geissler9b4d8b02021-02-19 12:26:16 -060044# gconv-cp1250, cp1251 and euc-jp needed for iconv to work in vim builds
45# also copied list from uninative
Andrew Geissler82c905d2020-04-13 13:39:40 -050046
47TOOLCHAIN_OUTPUTNAME = "${SDK_ARCH}-buildtools-extended-nativesdk-standalone-${DISTRO_VERSION}"
48
49SDK_TITLE = "Extended Build tools"