blob: 5d759aed94be7fb92b670babe1bb9aafeaff45de [file] [log] [blame]
Andrew Geissler95ac1b82021-03-31 14:34:31 -05001# To allow util-linux to optionally build-depend on cryptsetup, libuuid is
2# split out of the main recipe, as it's needed by cryptsetup
3
4require util-linux.inc
5
6inherit autotools gettext pkgconfig
7
8S = "${WORKDIR}/util-linux-${PV}"
9EXTRA_OECONF += "--disable-all-programs --enable-libuuid"
10LICENSE = "BSD-3-Clause"
11
Patrick Williams213cb262021-08-07 19:21:33 -050012do_install:append() {
Andrew Geissler95ac1b82021-03-31 14:34:31 -050013 rm -rf ${D}${datadir} ${D}${bindir} ${D}${base_bindir} ${D}${sbindir} ${D}${base_sbindir} ${D}${exec_prefix}/sbin
14}
15
16BBCLASSEXTEND = "native nativesdk"