blob: e943dc1762a554432f371c5d29e64831cc621cf7 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Vendor Package Management for Golang"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002HOMEPAGE = "https://github.com/Masterminds/glide"
3DESCRIPTION = "Glide is a Vendor Package Management for Golang"
Andrew Geissler82c905d2020-04-13 13:39:40 -05004LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=54905cf894f8cc416a92f4fc350c35b2"
6
7GO_IMPORT = "github.com/Masterminds/glide"
8SRC_URI = "git://${GO_IMPORT}"
9SRCREV = "8ed5b9292379d86c39592a7e6a58eb9c903877cf"
10
11inherit go
12
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050013# New Go versions has Go modules support enabled by default and cause the Glide
14# tool build to fail.
15export GO111MODULE = "off"
16
Patrick Williams213cb262021-08-07 19:21:33 -050017RDEPENDS:${PN}-dev += "bash"
18RDEPENDS:${PN}-ptest += "bash"
Andrew Geissler82c905d2020-04-13 13:39:40 -050019
20BBCLASSEXTEND = "native nativesdk"
21
22# for x86 ends with textrel in ${PN}
23# http://errors.yoctoproject.org/Errors/Details/185631/
24# ERROR: QA Issue: ELF binary '/work/i586-oe-linux/glide/0.13.1-r0/packages-split/glide/usr/bin/glide' has relocations in .text [textrel]
Patrick Williams213cb262021-08-07 19:21:33 -050025INSANE_SKIP:${PN} += "textrel"
Andrew Geissler82c905d2020-04-13 13:39:40 -050026
27# for aarch64 ends with textrel in ${PN}-ptest
28# http://errors.yoctoproject.org/Errors/Details/185633/
29# ERROR: QA Issue: ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/glide.test' has relocations in .text
30# ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/dependency/dependency.test' has relocations in .text
31# ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/repo/repo.test' has relocations in .text
32# ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/mirrors/mirrors.test' has relocations in .text
33# ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/cfg/cfg.test' has relocations in .text
34# ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/godep/strip/strip.test' has relocations in .text
35# ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/path/path.test' has relocations in .text
36# ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/tree/tree.test' has relocations in .text
37# ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/util/util.test' has relocations in .text
38# ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/action/action.test' has relocations in .text
39# ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/cache/cache.test' has relocations in .text [textrel]
Patrick Williams213cb262021-08-07 19:21:33 -050040INSANE_SKIP:${PN}-ptest += "textrel"
Andrew Geissler82c905d2020-04-13 13:39:40 -050041
42# fails to run task compile_ptest_base on mips
Patrick Williams213cb262021-08-07 19:21:33 -050043PTEST_ENABLED:mipsarch = "0"