blob: 33b177d1d0f718909980481d04f2fe4c39420175 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "jQuery is a fast, small, and feature-rich JavaScript library"
2HOMEPAGE = "https://jquery.com/"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06003DESCRIPTION = "${SUMMARY}"
Andrew Geissler82c905d2020-04-13 13:39:40 -05004LICENSE = "MIT"
5SECTION = "devel"
Andrew Geissler95ac1b82021-03-31 14:34:31 -05006LIC_FILES_CHKSUM = "file://${S}/${BP}.js;beginline=8;endline=10;md5=9c7c6e9ab275fc1e0d99cb7180ecd14c"
Andrew Geissler82c905d2020-04-13 13:39:40 -05007
Andrew Geissler475cb722020-07-10 16:00:51 -05008# unpack items to ${S} so the archiver can see them
9#
Andrew Geissler82c905d2020-04-13 13:39:40 -050010SRC_URI = "\
Andrew Geissler475cb722020-07-10 16:00:51 -050011 https://code.jquery.com/${BP}.js;name=js;subdir=${BP} \
12 https://code.jquery.com/${BP}.min.js;name=min;subdir=${BP} \
13 https://code.jquery.com/${BP}.min.map;name=map;subdir=${BP} \
Andrew Geissler82c905d2020-04-13 13:39:40 -050014 "
15
Andrew Geissler95ac1b82021-03-31 14:34:31 -050016SRC_URI[js.sha256sum] = "1fe2bb5390a75e5d61e72c107cab528fc3c29a837d69aab7d200e1dbb5dcd239"
17SRC_URI[min.sha256sum] = "ff1523fb7389539c84c65aba19260648793bb4f5e29329d2ee8804bc37a3fe6e"
18SRC_URI[map.sha256sum] = "399548fb0e7b146c12f5ba18099a47d594a970fee96212eee0ab4852f3e56782"
Andrew Geissler82c905d2020-04-13 13:39:40 -050019
20UPSTREAM_CHECK_REGEX = "jquery-(?P<pver>\d+(\.\d+)+)\.js"
21
William A. Kennington IIIac69b482021-06-02 12:28:27 -070022# https://github.com/jquery/jquery/issues/3927
23# There are ways jquery can expose security issues but any issues are in the apps exposing them
24# and there is little we can directly do
25CVE_CHECK_WHITELIST += "CVE-2007-2379"
26
Andrew Geissler82c905d2020-04-13 13:39:40 -050027inherit allarch
28
29do_install() {
30 install -d ${D}${datadir}/javascript/${BPN}/
Andrew Geissler475cb722020-07-10 16:00:51 -050031 install -m 644 ${S}/${BP}.js ${D}${datadir}/javascript/${BPN}/${BPN}.js
32 install -m 644 ${S}/${BP}.min.js ${D}${datadir}/javascript/${BPN}/${BPN}.min.js
33 install -m 644 ${S}/${BP}.min.map ${D}${datadir}/javascript/${BPN}/${BPN}.min.map
Andrew Geissler82c905d2020-04-13 13:39:40 -050034}
35
36PACKAGES = "${PN}"
Patrick Williams213cb262021-08-07 19:21:33 -050037FILES:${PN} = "${datadir}"
Andrew Geissler82c905d2020-04-13 13:39:40 -050038
39BBCLASSEXTEND += "native nativesdk"