blob: 282c28e2c4c2b02c4705dd33dd8aa7a375c33b3f [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Library providing simplified C and Python API to libsolv"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002HOMEPAGE = "https://github.com/rpm-software-management/libdnf"
3DESCRIPTION = "This library provides a high level package-manager. It's core library of dnf, PackageKit and rpm-ostree. It's replacement for deprecated hawkey library which it contains inside and uses librepo under the hood."
Andrew Geissler6ce62a22020-11-30 19:58:47 -06004LICENSE = "LGPLv2.1+"
Brad Bishopc342db32019-05-15 21:57:59 -04005LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
6
Andrew Geissler4b740dc2020-05-05 08:54:39 -05007SRC_URI = "git://github.com/rpm-software-management/libdnf;branch=dnf-4-master \
Brad Bishopc342db32019-05-15 21:57:59 -04008 file://0001-FindGtkDoc.cmake-drop-the-requirement-for-GTKDOC_SCA.patch \
9 file://0004-Set-libsolv-variables-with-pkg-config-cmake-s-own-mo.patch \
10 file://0001-Get-parameters-for-both-libsolv-and-libsolvext-libdn.patch \
11 file://0001-Add-WITH_TESTS-option.patch \
Andrew Geissler4b740dc2020-05-05 08:54:39 -050012 file://0001-Look-fo-sphinx-only-if-documentation-is-actually-ena.patch \
Andrew Geissler635e0e42020-08-21 15:58:33 -050013 file://enable_test_data_dir_set.patch \
Andrew Geissler95ac1b82021-03-31 14:34:31 -050014 file://0001-libdnf-config.h-avoid-the-use-of-non-portable-__WORD.patch \
Andrew Geissler09036742021-06-25 14:25:14 -050015 file://0001-drop-FindPythonInstDir.cmake.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040016 "
17
Andrew Geissler5f350902021-07-23 13:09:54 -040018SRCREV = "8e451380bf84bd76e3925cbae2a06bb0e56f5cd9"
William A. Kennington IIIac69b482021-06-02 12:28:27 -070019UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(?!4\.90)\d+(\.\d+)+)"
Brad Bishopc342db32019-05-15 21:57:59 -040020
21S = "${WORKDIR}/git"
22
Andrew Geissler4b740dc2020-05-05 08:54:39 -050023DEPENDS = "glib-2.0 libsolv libcheck librepo rpm gtk-doc libmodulemd json-c swig-native"
Brad Bishopc342db32019-05-15 21:57:59 -040024
25inherit gtk-doc gobject-introspection cmake pkgconfig distutils3-base
26
27EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DWITH_MAN=OFF -DPYTHON_DESIRED=3 \
28 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DWITH_GIR=ON', '-DWITH_GIR=OFF', d)} \
29 -DWITH_TESTS=OFF \
Andrew Geissler4b740dc2020-05-05 08:54:39 -050030 -DWITH_ZCHUNK=OFF \
31 -DWITH_HTML=OFF \
Brad Bishopc342db32019-05-15 21:57:59 -040032 "
Patrick Williams213cb262021-08-07 19:21:33 -050033EXTRA_OECMAKE:append:class-native = " -DWITH_GIR=OFF"
34EXTRA_OECMAKE:append:class-nativesdk = " -DWITH_GIR=OFF"
Brad Bishopc342db32019-05-15 21:57:59 -040035
36BBCLASSEXTEND = "native nativesdk"
Andrew Geissler82c905d2020-04-13 13:39:40 -050037PNBLACKLIST[libdnf] ?= "${@bb.utils.contains('PACKAGE_CLASSES', 'package_rpm', '', 'Does not build without package_rpm in PACKAGE_CLASSES due disabled rpm support in libsolv', d)}"
Brad Bishopc342db32019-05-15 21:57:59 -040038