blob: 3b20ce3e69fc3f50a3b5132c4c7cd81b6d6417c4 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001require libtool-${PV}.inc
2
3DEPENDS = ""
4
5SRC_URI += "file://prefix.patch"
6
7inherit native
8
9EXTRA_OECONF = " --with-libtool-sysroot=${STAGING_DIR_NATIVE}"
10
Patrick Williams213cb262021-08-07 19:21:33 -050011do_configure:prepend () {
Patrick Williamsc124f4f2015-09-15 14:41:29 -050012 # Remove any existing libtool m4 since old stale versions would break
13 # any upgrade
14 rm -f ${STAGING_DATADIR}/aclocal/libtool.m4
15 rm -f ${STAGING_DATADIR}/aclocal/lt*.m4
16}
17
18do_install () {
19 autotools_do_install
20 install -d ${D}${bindir}/
21 install -m 0755 ${HOST_SYS}-libtool ${D}${bindir}/${HOST_SYS}-libtool
22}