blob: c908bcb738f145d7ea810087f2944ec20c69f318 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Ninja is a small build system with a focus on speed."
Andrew Geissler6ce62a22020-11-30 19:58:47 -06002HOMEPAGE = "https://ninja-build.org/"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06003DESCRIPTION = "Ninja is a small build system with a focus on speed. It differs from other build systems in two major respects: it is designed to have its input files generated by a higher-level build system, and it is designed to run builds as fast as possible."
Andrew Geissler82c905d2020-04-13 13:39:40 -05004LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://COPYING;md5=a81586a64ad4e476c791cda7e2f2c52e"
6
7DEPENDS = "re2c-native ninja-native"
8
Andrew Geisslerd1e89492021-02-12 15:35:20 -06009SRCREV = "e72d1d581c945c158ed68d9bc48911063022a2c6"
Andrew Geissler82c905d2020-04-13 13:39:40 -050010
11SRC_URI = "git://github.com/ninja-build/ninja.git;branch=release"
12UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)"
13
14S = "${WORKDIR}/git"
15
16do_configure[noexec] = "1"
17
Patrick Williams213cb262021-08-07 19:21:33 -050018do_compile:class-native() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050019 python3 ./configure.py --bootstrap
20}
21
22do_compile() {
23 python3 ./configure.py
24 ninja
25}
26
27do_install() {
28 install -D -m 0755 ${S}/ninja ${D}${bindir}/ninja
29}
30
31BBCLASSEXTEND = "native nativesdk"