blob: a2bcc7f66116b999a3d29459bca0af793640dd80 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Additional utilities for the opkg package manager"
Patrick Williams213cb262021-08-07 19:21:33 -05002SUMMARY:update-alternatives-opkg = "Utility for managing the alternatives system"
Andrew Geissler82c905d2020-04-13 13:39:40 -05003SECTION = "base"
4HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://opkg.py;beginline=2;endline=18;md5=ffa11ff3c15eb31c6a7ceaa00cc9f986"
8PROVIDES += "${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'virtual/update-alternatives', '', d)}"
9
Andrew Geissler6ce62a22020-11-30 19:58:47 -060010SRC_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/${BPN}/snapshot/${BPN}-${PV}.tar.gz \
11 file://0001-update-alternatives-correctly-match-priority.patch \
12 "
Andrew Geissler82c905d2020-04-13 13:39:40 -050013UPSTREAM_CHECK_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils/refs/"
14
Andrew Geissler09036742021-06-25 14:25:14 -050015SRC_URI[md5sum] = "025b19744e5c7fc1c8380e17df1fcc64"
16SRC_URI[sha256sum] = "528635e674addea5c2b3a3268404ad04a952c4f410d17c3d754f5dd5529770c9"
Andrew Geissler82c905d2020-04-13 13:39:40 -050017
18TARGET_CC_ARCH += "${LDFLAGS}"
19
Patrick Williams213cb262021-08-07 19:21:33 -050020RDEPENDS:${PN} += "bash"
Andrew Geissler82c905d2020-04-13 13:39:40 -050021
22inherit perlnative
23
24# For native builds we use the host Python
25PYTHONRDEPS = "python3 python3-shell python3-io python3-math python3-crypt python3-logging python3-fcntl python3-pickle python3-compression python3-stringold"
Patrick Williams213cb262021-08-07 19:21:33 -050026PYTHONRDEPS:class-native = ""
Andrew Geissler82c905d2020-04-13 13:39:40 -050027
28PACKAGECONFIG = "python update-alternatives"
29PACKAGECONFIG[python] = ",,,${PYTHONRDEPS}"
30PACKAGECONFIG[update-alternatives] = ",,,"
31
32do_install() {
33 oe_runmake PREFIX=${prefix} DESTDIR=${D} install
34 if ! ${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'true', 'false', d)}; then
35 rm -f "${D}${bindir}/update-alternatives"
36 fi
37}
38
Patrick Williams213cb262021-08-07 19:21:33 -050039do_install:append:class-target() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050040 if ! ${@bb.utils.contains('PACKAGECONFIG', 'python', 'true', 'false', d)}; then
41 grep -lZ "/usr/bin/env.*python" ${D}${bindir}/* | xargs -0 rm
42 fi
43
44 if [ -e "${D}${bindir}/update-alternatives" ]; then
45 sed -i ${D}${bindir}/update-alternatives -e 's,/usr/bin,${bindir},g; s,/usr/lib,${nonarch_libdir},g'
46 fi
47}
48
49# These are empty and will pull python3-dev into images where it wouldn't
50# have been otherwise, so don't generate them.
Patrick Williams213cb262021-08-07 19:21:33 -050051PACKAGES:remove = "${PN}-dev ${PN}-staticdev"
Andrew Geissler82c905d2020-04-13 13:39:40 -050052
53PACKAGES =+ "update-alternatives-opkg"
Patrick Williams213cb262021-08-07 19:21:33 -050054FILES:update-alternatives-opkg = "${bindir}/update-alternatives"
55RPROVIDES:update-alternatives-opkg = "update-alternatives update-alternatives-cworth"
56RREPLACES:update-alternatives-opkg = "update-alternatives-cworth"
57RCONFLICTS:update-alternatives-opkg = "update-alternatives-cworth"
Andrew Geissler82c905d2020-04-13 13:39:40 -050058
Patrick Williams213cb262021-08-07 19:21:33 -050059pkg_postrm:update-alternatives-opkg() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050060 rm -rf $D${nonarch_libdir}/opkg/alternatives
61 rmdir $D${nonarch_libdir}/opkg || true
62}
63
64BBCLASSEXTEND = "native nativesdk"
65
66CLEANBROKEN = "1"