blob: ef18ccf63a845545e8bcc6dccd4d1486ad26eeb8 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Open Package Manager"
Patrick Williams213cb262021-08-07 19:21:33 -05002SUMMARY:libopkg = "Open Package Manager library"
Andrew Geissler82c905d2020-04-13 13:39:40 -05003SECTION = "base"
4HOMEPAGE = "http://code.google.com/p/opkg/"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06005DESCRIPTION = "Opkg is a lightweight package management system based on Ipkg."
Andrew Geissler82c905d2020-04-13 13:39:40 -05006BUGTRACKER = "http://code.google.com/p/opkg/issues/list"
7LICENSE = "GPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
9 file://src/opkg.c;beginline=4;endline=18;md5=d6200b0f2b41dee278aa5fad333eecae"
10
11DEPENDS = "libarchive"
12
13PE = "1"
14
15SRC_URI = "http://downloads.yoctoproject.org/releases/${BPN}/${BPN}-${PV}.tar.gz \
16 file://opkg.conf \
17 file://0001-opkg_conf-create-opkg.lock-in-run-instead-of-var-run.patch \
18 file://run-ptest \
19"
20
Andrew Geissler09036742021-06-25 14:25:14 -050021SRC_URI[md5sum] = "5dc41ad37d88803b5e0f456a9c5a0811"
22SRC_URI[sha256sum] = "a1214a75fa34fb9228db8da47308e0e711b1c93fd8938cf164c10fd28eb50f1e"
Andrew Geissler82c905d2020-04-13 13:39:40 -050023
24# This needs to be before ptest inherit, otherwise all ptest files end packaged
25# in libopkg package if OPKGLIBDIR == libdir, because default
26# PTEST_PATH ?= "${libdir}/${BPN}/ptest"
27PACKAGES =+ "libopkg"
28
29inherit autotools pkgconfig ptest
30
31target_localstatedir := "${localstatedir}"
32OPKGLIBDIR ??= "${target_localstatedir}/lib"
33
34PACKAGECONFIG ??= "libsolv"
35
36PACKAGECONFIG[gpg] = "--enable-gpg,--disable-gpg,\
37 gnupg gpgme libgpg-error,\
38 ${@ "gnupg" if ("native" in d.getVar("PN")) else "gnupg-gpg"}\
39 "
40PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl"
41PACKAGECONFIG[ssl-curl] = "--enable-ssl-curl,--disable-ssl-curl,curl openssl"
42PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
43PACKAGECONFIG[sha256] = "--enable-sha256,--disable-sha256"
44PACKAGECONFIG[libsolv] = "--with-libsolv,--without-libsolv,libsolv"
45
46EXTRA_OECONF += " --disable-pathfinder"
Patrick Williams213cb262021-08-07 19:21:33 -050047EXTRA_OECONF:class-native = "--localstatedir=/${@os.path.relpath('${localstatedir}', '${STAGING_DIR_NATIVE}')} --sysconfdir=/${@os.path.relpath('${sysconfdir}', '${STAGING_DIR_NATIVE}')}"
Andrew Geissler82c905d2020-04-13 13:39:40 -050048
Patrick Williams213cb262021-08-07 19:21:33 -050049do_install:append () {
Andrew Geissler82c905d2020-04-13 13:39:40 -050050 install -d ${D}${sysconfdir}/opkg
51 install -m 0644 ${WORKDIR}/opkg.conf ${D}${sysconfdir}/opkg/opkg.conf
52 echo "option lists_dir ${OPKGLIBDIR}/opkg/lists" >>${D}${sysconfdir}/opkg/opkg.conf
53
54 # We need to create the lock directory
55 install -d ${D}${OPKGLIBDIR}/opkg
56}
57
58do_install_ptest () {
59 sed -i -e '/@echo $^/d' ${D}${PTEST_PATH}/tests/Makefile
60 sed -i -e '/@PYTHONPATH=. $(PYTHON) $^/a\\t@if [ "$$?" != "0" ];then echo "FAIL:"$^;else echo "PASS:"$^;fi' ${D}${PTEST_PATH}/tests/Makefile
61}
62
Patrick Williams213cb262021-08-07 19:21:33 -050063WARN_QA:append += "openssl-deprecation"
Andrew Geissler09036742021-06-25 14:25:14 -050064QAPKGTEST[openssl-deprecation] = "package_qa_check_openssl_deprecation"
65def package_qa_check_openssl_deprecation (package, d, messages):
66 sane = True
67
68 pkgconfig = (d.getVar("PACKAGECONFIG") or "").split()
69 if pkgconfig and 'openssl' in pkgconfig:
70 package_qa_add_message(messages, 'openssl-deprecation', '"openssl" in opkg.bb PACKAGECONFIG. Feed signature checking with OpenSSL will be deprecated in the next opkg release. Consider using GPG checking instead.')
71 sane = False
72
73 return sane
74
75
Patrick Williams213cb262021-08-07 19:21:33 -050076RDEPENDS:${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-arch-config libarchive"
77RDEPENDS:${PN}:class-native = ""
78RDEPENDS:${PN}:class-nativesdk = ""
79RDEPENDS:${PN}-ptest += "make binutils python3-core python3-compression"
80RREPLACES:${PN} = "opkg-nogpg opkg-collateral"
81RCONFLICTS:${PN} = "opkg-collateral"
82RPROVIDES:${PN} = "opkg-collateral"
Andrew Geissler82c905d2020-04-13 13:39:40 -050083
Patrick Williams213cb262021-08-07 19:21:33 -050084FILES:libopkg = "${libdir}/*.so.* ${OPKGLIBDIR}/opkg/"
Andrew Geissler82c905d2020-04-13 13:39:40 -050085
86BBCLASSEXTEND = "native nativesdk"
87
Patrick Williams213cb262021-08-07 19:21:33 -050088CONFFILES:${PN} = "${sysconfdir}/opkg/opkg.conf"