blob: b77ad24b58f25588115c519154f328fc8e5a13a4 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001DESCRIPTION = "libxml-perl is a collection of smaller Perl modules, scripts, and \
2documents for working with XML in Perl. libxml-perl software \
3works in combination with XML::Parser, PerlSAX, XML::DOM, \
4XML::Grove and others."
Brad Bishopd7bf8c12018-02-25 22:55:05 -05005HOMEPAGE = "http://search.cpan.org/dist/libxml-perl/"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05006SUMMARY = "Collection of Perl modules for working with XML"
7SECTION = "libs"
8LICENSE = "Artistic-1.0 | GPL-1.0+"
9PR = "r3"
10
11LIC_FILES_CHKSUM = "file://README;beginline=33;endline=35;md5=1705549eef7577a3d6ba71123a1f0ce8"
12
13DEPENDS += "libxml-parser-perl"
14
15SRC_URI = "http://www.cpan.org/modules/by-module/XML/${BPN}-${PV}.tar.gz"
16
17SRC_URI[md5sum] = "0ed5fbdda53d1301ddaed88db10503bb"
18SRC_URI[sha256sum] = "4571059b7b5d48b7ce52b01389e95d798bf5cf2020523c153ff27b498153c9cb"
19
20EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
21
Brad Bishop316dfdd2018-06-25 12:45:53 -040022inherit cpan ptest-perl
Patrick Williamsc124f4f2015-09-15 14:41:29 -050023
24do_compile() {
25 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
26 cpan_do_compile
27}
28
Patrick Williams213cb262021-08-07 19:21:33 -050029RDEPENDS:${PN} += "perl-module-carp perl-module-overload perl-module-universal perl-module-io-handle"
30RDEPENDS:${PN}-ptest += "libxml-parser-perl perl-module-file-glob"