blob: 065a2c7b4fb5e170fe101826d0de1c39b4c3b7e3 [file] [log] [blame]
Andrew Geissler6ce62a22020-11-30 19:58:47 -06001DESCRIPTION = "Powerful Python library for atomic file writes"
2HOMEPAGE = "https://github.com/untitaker/python-atomicwrites"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=91cc36cfafeefb7863673bcfcb1d4da4"
5
6SRC_URI[md5sum] = "b5cc15c8f9f180a48665f9aacf91d817"
7SRC_URI[sha256sum] = "ae70396ad1a434f9c7046fd2dd196fc04b12f9e91ffb859164193be8b6168a7a"
8
9inherit pypi setuptools3 ptest
10
11SRC_URI += " \
12 file://run-ptest \
13"
14
Patrick Williams213cb262021-08-07 19:21:33 -050015RDEPENDS:${PN}-ptest += " \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060016 ${PYTHON_PN}-pytest \
17 ${PYTHON_PN}-unixadmin \
18"
19
20do_install_ptest() {
21 install -d ${D}${PTEST_PATH}/tests
22 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
23}
24
Patrick Williams213cb262021-08-07 19:21:33 -050025RDEPENDS:${PN} = "${PYTHON_PN}-misc"