blob: 27feaa8cde78626dae4e4c053934f0ba53d4d00a [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Compact getty terminal handler for virtual consoles only"
2SECTION = "console/utils"
3HOMEPAGE = "http://sourceforge.net/projects/mingetty/"
Andrew Geissler95ac1b82021-03-31 14:34:31 -05004DESCRIPTION = "This is a small Linux console getty that is started on the Linux text console, asks for a login name and then tranfers over to login directory. Is extended to allow automatic login and starting any app."
Patrick Williamsc124f4f2015-09-15 14:41:29 -05005LICENSE = "GPLv2"
6PR = "r3"
7
8LIC_FILES_CHKSUM = "file://COPYING;md5=0c56db0143f4f80c369ee3af7425af6e"
9SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz"
10
11SRC_URI[md5sum] = "2a75ad6487ff271424ffc00a64420990"
12SRC_URI[sha256sum] = "0f55c90ba4faa913d91ef99cbf5cb2eb4dbe2780314c3bb17953f849c8cddd17"
13
14# substitute our CFLAGS for "-O2 -Wall -W -pipe"
15#
16EXTRA_OEMAKE = "CC='${CC}' \
17 CFLAGS='${CFLAGS} -D_GNU_SOURCE'"
18
19do_install(){
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020 sed -i -e "s;SBINDIR=/sbin;SBINDIR=$base_sbindir;" ${S}/Makefile
Patrick Williamsc124f4f2015-09-15 14:41:29 -050021 install -d ${D}${mandir}/man8 ${D}/${base_sbindir}
22 oe_runmake install DESTDIR=${D}
23}
24
25inherit update-alternatives
26
Patrick Williams213cb262021-08-07 19:21:33 -050027ALTERNATIVE:${PN} = "getty"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050028ALTERNATIVE_LINK_NAME[getty] = "${base_sbindir}/getty"
29ALTERNATIVE_TARGET[getty] = "${base_sbindir}/mingetty"
30ALTERNATIVE_PRIORITY = "10"