blob: dcd2698ee51c9dd2eca37f547c2426fca04a1261 [file] [log] [blame]
Andrew Geissler90fd73c2021-03-05 15:25:55 -06001SUMMARY = "in-depth comparison of files, archives, and directories"
2DESCRIPTION = "Tries to get to the bottom of what makes files or directories \
3different. It will recursively unpack archives of many kinds and transform \
4various binary formats into more human-readable form to compare them. \
5It can compare two tarballs, ISO images, or PDF just as easily."
6HOMEPAGE = "https://diffoscope.org/"
7BUGTRACKER = "https://salsa.debian.org/reproducible-builds/diffoscope/-/issues"
8LICENSE = "GPL-3.0+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
10
11PYPI_PACKAGE = "diffoscope"
12
13inherit pypi setuptools3
14
Patrick Williams213cb262021-08-07 19:21:33 -050015SRC_URI[sha256sum] = "17790d463b757b6d05e0734db06ba5e79ac63fb64bf9b834dc7440477582a38a"
Andrew Geissler90fd73c2021-03-05 15:25:55 -060016
Patrick Williams213cb262021-08-07 19:21:33 -050017RDEPENDS:${PN} += "binutils vim squashfs-tools python3-libarchive-c python3-magic python3-rpm"
Andrew Geissler90fd73c2021-03-05 15:25:55 -060018
19# Dependencies don't build for musl
Patrick Williams213cb262021-08-07 19:21:33 -050020COMPATIBLE_HOST:libc-musl = 'null'
Andrew Geissler90fd73c2021-03-05 15:25:55 -060021
Patrick Williams213cb262021-08-07 19:21:33 -050022do_install:append:class-native() {
Andrew Geissler90fd73c2021-03-05 15:25:55 -060023 create_wrapper ${D}${bindir}/diffoscope \
24 MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc \
25 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
Andrew Geisslerc926e172021-05-07 16:11:35 -050026 LD_LIBRARY_PATH=${STAGING_LIBDIR_NATIVE} \
Andrew Geissler90fd73c2021-03-05 15:25:55 -060027 RPM_ETCCONFIGDIR=${STAGING_DIR_NATIVE}
28}
29
30BBCLASSEXTEND = "native"