blob: 92967301d4972e733032e6845f38f3fbdf4eb577 [file] [log] [blame]
Brad Bishopbec4ebc2022-08-03 09:55:16 -04001require recipes-devtools/gcc/gcc-${PV}.inc
2require recipes-devtools/gcc/gcc-target.inc
3require recipes-devtools/gcc/gcc-arm-common.inc
4
5# Building with thumb enabled on armv4t armv5t fails with
6# | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7438:(.text.unlikely+0x2fa): relocation truncated to fit: R_ARM_THM_CALL against symbol `fancy_abort(char const*, int, char const*)' defined in .glue_7 section in linker stubs
7# | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7442:(.text.unlikely+0x318): additional relocation overflows omitted from the output
8ARM_INSTRUCTION_SET:armv4 = "arm"
9ARM_INSTRUCTION_SET:armv5 = "arm"
10
11ARMFPARCHEXT:armv6 = "${@'+fp' if d.getVar('TARGET_FPU') == 'hard' else ''}"
12ARMFPARCHEXT:armv7a = "${@'+fp' if d.getVar('TARGET_FPU') == 'hard' else ''}"
13ARMFPARCHEXT:armv7ve = "${@'+fp' if d.getVar('TARGET_FPU') == 'hard' else ''}"
14
15BBCLASSEXTEND = "nativesdk"