blob: e5c662e4d027526bf15b7792901de7242b4e99d8 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001DESCRIPTION = "Initial Attestation PSA certification tests (psa-arch-test) for Trusted Services"
2
3TS_ENV = "arm-linux"
4
5require ts-psa-api-test-common_${PV}.inc
6
7OECMAKE_SOURCEPATH = "${S}/deployments/psa-api-test/initial_attestation/${TS_ENV}"
8
9PSA_TEST = "psa-iat-api-test"
10
11# psa-arch-tests for INITIAL_ATTESTATION suite can't be built with pre-built qcbor
12# Fetch qcbor sources as a temp work-around and pass PSA_TARGET_QCBOR to psa-arch-tests
13SRC_URI += "git://github.com/laurencelundblade/QCBOR.git;name=psaqcbor;protocol=https;branch=master;destsuffix=git/psaqcbor \
Patrick Williams92b42cb2022-09-03 06:53:57 -050014 "
15SRCREV_psaqcbor = "42272e466a8472948bf8fca076d113b81b99f0e0"
16
17EXTRA_OECMAKE += "-DPSA_TARGET_QCBOR=${WORKDIR}/git/psaqcbor \
18 "
Patrick Williams2194f502022-10-16 14:26:09 -050019
20# Mbedtls 3.1.0 does not compile with clang.
21# This can be removed after TS updated required mbedtls version
22TOOLCHAIN = "gcc"