blob: 5af856ad344c8c3733cc86403824f343f58e51d0 [file] [log] [blame]
Patrick Williams2194f502022-10-16 14:26:09 -05001DESCRIPTION = "open62541 is an implementation of OPC UA (OPC Unified Architecture)"
2HOMEPAGE = "https://github.com/open62541/open62541.git"
3LICENSE = "MPL-2.0 & BSD-3-Clause & MIT"
4LIC_FILES_CHKSUM = "\
5 file://LICENSE;md5=815ca599c9df247a0c7f619bab123dad \
6 file://deps/mdnsd/LICENSE;md5=3bb4047dc4095cd7336de3e2a9be94f0 \
7 file://deps/mqtt-c/LICENSE;md5=9226377baf0b79174c89a1ab55592456 \
8"
9
10SRCREV_FORMAT = "opcua_mdnsd_ua-nodeset_mqtt-c"
11SRCREV_opcua = "ff73268829359639531ff02905c889f73a77b408"
12SRCREV_mdnsd = "3151afe5899dba5125dffa9f4cf3ae1fe2edc0f0"
13SRCREV_ua-nodeset = "f71b3f411d5cb16097c3ae0c744f67ad45535ffb"
14SRCREV_mqtt-c = "f69ce1e7fd54f3b1834c9c9137ce0ec5d703cb4d"
15
16SRC_URI = " \
17 git://github.com/open62541/open62541.git;name=opcua;branch=1.3;protocol=https \
18 git://github.com/Pro/mdnsd.git;name=mdnsd;protocol=https;branch=master;destsuffix=git/deps/mdnsd \
19 git://github.com/OPCFoundation/UA-Nodeset;name=ua-nodeset;protocol=https;branch=v1.04;destsuffix=git/deps/ua-nodeset \
20 git://github.com/LiamBindle/MQTT-C.git;name=mqtt-c;protocol=https;branch=master;destsuffix=git/deps/mqtt-c \
21 file://0001-fix-build-do-not-install-git-files.patch \
22"
23
24S = "${WORKDIR}/git"
25
26inherit cmake python3native
27
28EXTRA_OECMAKE += "\
29 -DBUILD_SHARED_LIBS=ON \
30 -DUA_NAMESPACE_ZERO=FULL \
31 -DUA_LOGLEVEL=600 \
32"
33
34PACKAGECONFIG ?= "encryption pubsub pubsub-eth"
35PACKAGECONFIG[amalgamation] = "-DUA_ENABLE_AMALGAMATION=ON, -DUA_ENABLE_AMALGAMATION=OFF"
36PACKAGECONFIG[encryption] = "-DUA_ENABLE_ENCRYPTION=ON, -DUA_ENABLE_ENCRYPTION=OFF, mbedtls"
37PACKAGECONFIG[pubsub] = "-DUA_ENABLE_PUBSUB=ON, -DUA_ENABLE_PUBSUB=OFF"
38PACKAGECONFIG[pubsub-eth] = "-DUA_ENABLE_PUBSUB_ETH_UADP=ON, -DUA_ENABLE_PUBSUB_ETH_UADP=OFF"
39
40do_configure:prepend:toolchain-clang:riscv64() {
41 sed -i -e 's/set(CMAKE_INTERPROCEDURAL_OPTIMIZATION ON)/set(CMAKE_INTERPROCEDURAL_OPTIMIZATION OFF)/' ${S}/CMakeLists.txt
42}
43
44do_configure:prepend:toolchain-clang:riscv32() {
45 sed -i -e 's/set(CMAKE_INTERPROCEDURAL_OPTIMIZATION ON)/set(CMAKE_INTERPROCEDURAL_OPTIMIZATION OFF)/' ${S}/CMakeLists.txt
46}
47