blob: 17c8c5360c9e5d2223bdc3be7db082a070d1ad79 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Program for providing universal TLS/SSL tunneling service"
2DESCRIPTION = "SSL encryption wrapper between remote client and local (inetd-startable) or remote server."
3HOMEPAGE = "https://www.stunnel.org/"
4SECTION = "net"
5LICENSE = "GPL-2.0-or-later"
6LIC_FILES_CHKSUM = "file://COPYING.md;md5=d8a2866ad5ebf3a2d2ce27279472875a"
7
8DEPENDS = "autoconf-archive libnsl2 openssl"
9
10SRC_URI = "https://stunnel.org/archive/5.x/${BP}.tar.gz \
11 file://fix-openssl-no-des.patch \
12"
13
Patrick Williams2194f502022-10-16 14:26:09 -050014SRC_URI[sha256sum] = "558178704d1aa5f6883aac6cc5d6bbf2a5714c8a0d2e91da0392468cee9f579c"
Andrew Geissler9aee5002022-03-30 16:27:02 +000015
16inherit autotools bash-completion pkgconfig
17
18PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6 systemd', d)} libwrap"
19
20PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
21PACKAGECONFIG[libwrap] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"
22PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd"
23
24EXTRA_OECONF += "--with-ssl='${STAGING_EXECPREFIXDIR}' --disable-fips"
25
26# When cross compiling, configure defaults to nobody, but provides no option to change it.
27EXTRA_OEMAKE += "DEFAULT_GROUP='nogroup'"
28
29# stunnel3 is a Perl wrapper to allow use of the legacy stunnel 3.x commandline
30# syntax with stunnel >= 4.05
31PACKAGES =+ "stunnel3"
32FILES:stunnel3 = "${bindir}/stunnel3"
33RDEPENDS:stunnel3 += "${PN} perl"