blob: ddfce3f391e229ab7e43af177d7fc21ce10b6969 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001DESCRIPTION = "Hardware identification and configuration data"
2HOMEPAGE = "https://github.com/vcrhonek/hwdata"
3SECTION = "System/Base"
4
5LICENSE = "GPL-2.0-or-later | XFree86-1.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=1556547711e8246992b999edd9445a57"
7
Patrick Williams2194f502022-10-16 14:26:09 -05008SRCREV = "75df73ae53e2bb878b5dc62036679efb69210222"
Andrew Geissler9aee5002022-03-30 16:27:02 +00009SRC_URI = "git://github.com/vcrhonek/${BPN}.git;branch=master;protocol=https"
10S = "${WORKDIR}/git"
11
12inherit allarch
13
14do_configure() {
15 ${S}/configure --datadir=${datadir} --libdir=${libdir}
16}
17
18do_compile[noexec] = "1"
19
20do_install() {
21 oe_runmake install DESTDIR=${D}
22}
23
24FILES:${PN} = "${libdir}/* \
25 ${datadir}/* "