blob: c09a01b2ae0242d45cfecdd99d558732aff8cfab [file] [log] [blame]
Patrick Williams2194f502022-10-16 14:26:09 -05001SUMMARY = "The new Python SDK for Sentry.io"
2DESCRIPTION = "This is the next line of the Python SDK \
3for Sentry, intended to replace the raven package on PyPI."
4HOMEPAGE = "https://github.com/getsentry/sentry-python"
5LICENSE = "BSD-2-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=0c79f8d3c91fc847350efd28bfe0a341"
7
8RDEPENDS:${PN} += "\
9 ${PYTHON_PN}-urllib3 \
10 ${PYTHON_PN}-core \
11 ${PYTHON_PN}-json \
12 ${PYTHON_PN}-logging \
13 ${PYTHON_PN}-threading \
14 ${PYTHON_PN}-compression \
15 ${PYTHON_PN}-datetime \
16"
17
18SRC_URI[sha256sum] = "4fbace9a763285b608c06f01a807b51acb35f6059da6a01236654e08b0ee81ff"
19
20PYPI_PACKAGE = "sentry-sdk"
21
22inherit pypi setuptools3