blob: 073105dffde2cd05afacdcceecc4677e7444b89c [file] [log] [blame]
Patrick Williams2194f502022-10-16 14:26:09 -05001SUMMARY = "A suite of libcamera-based apps for the Raspberry Pi"
2DESCRIPTION = "This is a small suite of libcamera-based apps that aim to \
3copy the functionality of the existing \"raspicam\" apps."
4HOMEPAGE = "https://github.com/raspberrypi/libcamera-apps"
5SECTION = "console/utils"
6
7LICENSE = "BSD-2-Clause"
8LIC_FILES_CHKSUM = "file://license.txt;md5=a0013d1b383d72ba4bdc5b750e7d1d77"
9
10SRC_URI = "\
11 git://github.com/raspberrypi/libcamera-apps.git;protocol=https;branch=main \
12"
13SRCREV = "22a52590c33a813743b4e6337478c208201c77b1"
14
15S = "${WORKDIR}/git"
16
17COMPATIBLE_MACHINE = "^rpi$"
18
19DEPENDS = "libcamera libexif jpeg tiff libpng boost"
20
21inherit cmake pkgconfig
22
23EXTRA_OECMAKE = "\
24 -DCMAKE_BUILD_TYPE=Release \
25 -DBoost_INCLUDE_DIR=${STAGING_INCDIR} \
26 -DCMAKE_LIBRARY_PATH=${STAGING_LIBDIR} \
27"
28
29EXTRA_OECMAKE:append:raspberrypi3 = " -DENABLE_COMPILE_FLAGS_FOR_TARGET=armv8-neon"
30EXTRA_OECMAKE:append:raspberrypi4 = " -DENABLE_COMPILE_FLAGS_FOR_TARGET=armv8-neon"
31
32PACKAGECONFIG[x11] = "-DENABLE_X11=1,-DENABLE_X11=0"
33PACKAGECONFIG[qt] = "-DENABLE_QT=1,-DENABLE_QT=0"
34PACKAGECONFIG[opencv] = "-DENABLE_OPENCV=1,-DENABLE_OPENCV=0"
35PACKAGECONFIG[tensorflow-lite] = "-DENABLE_TFLITE=1,-DENABLE_TFLITE=0"
36
37# Build does not version solibs so we need to change the suffix
38SOLIBS = ".so"
39FILES_SOLIBSDEV = ""
40
41do_install:append() {
42 # Requires python3-core which not all systems may have
43 rm ${D}/${bindir}/camera-bug-report
44}