blob: 4d7323bd2f601e62be16ed626adbe59327954c18 [file] [log] [blame]
Andrew Geissler220dafd2023-10-04 10:18:08 -05001Upstream-Status: Pending
2
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05003Description: just hard code rather than deal with circular deps
4Forwarded: not-needed
5--- a/system/core/adb/adb.cpp
6+++ b/system/core/adb/adb.cpp
7@@ -44,8 +44,6 @@
8 #include <android-base/parsenetaddress.h>
9 #include <android-base/stringprintf.h>
10 #include <android-base/strings.h>
11-#include <build/version.h>
12-#include <platform_tools_version.h>
13
14 #include "adb_auth.h"
15 #include "adb_io.h"
16@@ -69,7 +67,7 @@
17 "Version %s-%s\n"
18 "Installed as %s\n",
19 ADB_VERSION_MAJOR, ADB_VERSION_MINOR, ADB_SERVER_VERSION,
20- PLATFORM_TOOLS_VERSION, android::build::GetBuildNumber().c_str(),
21+ PLATFORM_TOOLS_VERSION, "debian",
22 android::base::GetExecutablePath().c_str());
23 }
24
25--- a/system/core/fastboot/fastboot.cpp
26+++ b/system/core/fastboot/fastboot.cpp
27@@ -59,10 +59,8 @@
28 #include <android-base/stringprintf.h>
29 #include <android-base/strings.h>
30 #include <android-base/unique_fd.h>
31-#include <build/version.h>
32 #include <libavb/libavb.h>
33 #include <liblp/liblp.h>
34-#include <platform_tools_version.h>
35 #include <sparse/sparse.h>
36 #include <ziparchive/zip_archive.h>
37
38@@ -1680,7 +1678,7 @@
39 setvbuf(stdout, nullptr, _IONBF, 0);
40 setvbuf(stderr, nullptr, _IONBF, 0);
41 } else if (name == "version") {
42- fprintf(stdout, "fastboot version %s-%s\n", PLATFORM_TOOLS_VERSION, android::build::GetBuildNumber().c_str());
43+ fprintf(stdout, "fastboot version %s-%s\n", PLATFORM_TOOLS_VERSION, "debian");
44 fprintf(stdout, "Installed as %s\n", android::base::GetExecutablePath().c_str());
45 return 0;
46 #if !defined(_WIN32)