blob: f2354f1d4ff3c13fcab5cfb57e078924a21c2640 [file] [log] [blame]
George Hungbd21fb242020-08-03 13:39:03 +08001PR = "r1"
2PV = "1.0+git${SRCPV}"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5
6SRC_URI = "git://github.com/quanta-bmc/read-margin-temp.git"
George Hungaa395cc2021-03-23 17:55:01 +08007SRCREV = "898f158b56f8cc16474dfc46e032a0d754b437c6"
George Hungbd21fb242020-08-03 13:39:03 +08008S = "${WORKDIR}/git"
9
10inherit autotools pkgconfig
11inherit meson
12
13DEPENDS += " nlohmann-json"
14DEPENDS += " sdbusplus"
George Hungbd21fb242020-08-03 13:39:03 +080015DEPENDS += " sdeventplus"
16DEPENDS += " phosphor-dbus-interfaces"
17RDEPENDS_${PN} += " bash"
18
19FILES_${PN} = "${bindir}/read-margin-temp"
20
21do_install() {
22 install -d ${D}${bindir}
23 install -m 0755 read-margin-temp ${D}${bindir}
24}
25