blob: bd2e75be73465f841697ea99714a2ee204f00d92 [file] [log] [blame]
George Hungbd21fb242020-08-03 13:39:03 +08001PR = "r1"
2PV = "1.0+git${SRCPV}"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5
6SRC_URI = "git://github.com/quanta-bmc/read-margin-temp.git"
7SRCREV = "ca2dc1bf7f34d517f0edc59dd3596c3a76c3d7a1"
8S = "${WORKDIR}/git"
9
10inherit autotools pkgconfig
11inherit meson
12
13DEPENDS += " nlohmann-json"
14DEPENDS += " sdbusplus"
15DEPENDS += " sdbusplus-native"
16DEPENDS += " sdeventplus"
17DEPENDS += " phosphor-dbus-interfaces"
18RDEPENDS_${PN} += " bash"
19
20FILES_${PN} = "${bindir}/read-margin-temp"
21
22do_install() {
23 install -d ${D}${bindir}
24 install -m 0755 read-margin-temp ${D}${bindir}
25}
26