blob: bac91d37366c9b955217bb689ced4a53cf258465 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Simple DirectMedia Layer"
2DESCRIPTION = "Simple DirectMedia Layer is a cross-platform multimedia \
3library designed to provide low level access to audio, keyboard, mouse, \
4joystick, 3D hardware via OpenGL, and 2D video framebuffer."
5HOMEPAGE = "http://www.libsdl.org"
6BUGTRACKER = "http://bugzilla.libsdl.org/"
7
8SECTION = "libs"
9
10LICENSE = "Zlib"
11LIC_FILES_CHKSUM = "file://COPYING.txt;md5=02ee26814dd044bd7838ae24e05b880f"
12
13PROVIDES = "virtual/libsdl2"
14
15SRC_URI = "http://www.libsdl.org/release/SDL2-${PV}.tar.gz \
16 file://more-gen-depends.patch \
17"
18
19S = "${WORKDIR}/SDL2-${PV}"
20
21SRC_URI[md5sum] = "f2ecfba915c54f7200f504d8b48a5dfe"
22SRC_URI[sha256sum] = "255186dc676ecd0c1dbf10ec8a2cc5d6869b5079d8a38194c2aecdff54b324b1"
23
24inherit autotools lib_package binconfig pkgconfig
25
Brad Bishopc342db32019-05-15 21:57:59 -040026CVE_PRODUCT = "simple_directmedia_layer sdl"
27
Brad Bishop19323692019-04-05 15:28:33 -040028EXTRA_OECONF = "--disable-oss --disable-esd --disable-arts \
29 --disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \
30 --disable-video-dummy \
31 --enable-pthreads \
32 --enable-sdl-dlopen \
33 --disable-rpath \
34 --disable-sndio \
35 "
36
37# opengl packageconfig factored out to make it easy for distros
38# and BSP layers to pick either (desktop) opengl, gles2, or no GL
39PACKAGECONFIG_GL ?= "${@bb.utils.filter('DISTRO_FEATURES', 'opengl', d)}"
40
41PACKAGECONFIG_class-native = "x11"
42PACKAGECONFIG_class-nativesdk = "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
43PACKAGECONFIG ??= " \
44 ${PACKAGECONFIG_GL} \
45 ${@bb.utils.filter('DISTRO_FEATURES', 'alsa directfb pulseaudio x11', d)} \
46 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland gles2', '', d)} \
47"
48PACKAGECONFIG[alsa] = "--enable-alsa --disable-alsatest,--disable-alsa,alsa-lib,"
49PACKAGECONFIG[directfb] = "--enable-video-directfb,--disable-video-directfb,directfb"
50PACKAGECONFIG[gles2] = "--enable-video-opengles,--disable-video-opengles,virtual/libgles2"
51PACKAGECONFIG[jack] = "--enable-jack,--disable-jack,jack"
52PACKAGECONFIG[kmsdrm] = "--enable-video-kmsdrm,--disable-video-kmsdrm,libdrm virtual/libgbm"
53PACKAGECONFIG[opengl] = "--enable-video-opengl,--disable-video-opengl,virtual/libgl"
54PACKAGECONFIG[pulseaudio] = "--enable-pulseaudio,--disable-pulseaudio,pulseaudio"
55PACKAGECONFIG[tslib] = "--enable-input-tslib,--disable-input-tslib,tslib"
56PACKAGECONFIG[wayland] = "--enable-video-wayland,--disable-video-wayland,wayland-native wayland wayland-protocols libxkbcommon"
57PACKAGECONFIG[x11] = "--enable-video-x11,--disable-video-x11,virtual/libx11 libxext libxrandr libxrender"
58
59EXTRA_AUTORECONF += "--include=acinclude --exclude=autoheader"
60
61do_configure_prepend() {
62 # Remove old libtool macros.
63 MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
64 for i in ${MACROS}; do
65 rm -f ${S}/acinclude/$i
66 done
67 export SYSROOT=$PKG_CONFIG_SYSROOT_DIR
68}
69
70FILES_${PN}-dev += "${libdir}/cmake"
71
72BBCLASSEXTEND = "native nativesdk"