blob: 5004973186d2d409d2c8e528649cbf7d68484f34 [file] [log] [blame]
Brad Bishop5baa96f2015-11-18 10:56:38 -05001FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
Brad Bishop39beab92018-06-06 16:16:23 -04002SRC_URI += "file://0001-json-Use-int-long.__str__-to-convert-subclasses.patch"
Brad Bishop5baa96f2015-11-18 10:56:38 -05003
Brad Bishop5baa96f2015-11-18 10:56:38 -05004require wsgiref-${PYTHON_MAJMIN}-manifest.inc
5
Brad Bishop027ba2b2018-06-07 19:10:54 -04006PROVIDES_prepend = "${PN}-spwd "
7PACKAGES_prepend = "${PN}-spwd "
Brad Bishop5baa96f2015-11-18 10:56:38 -05008
9SUMMARY_${PN}-spwd = "Shadow database support"
10RDEPENDS_${PN}-spwd = "${PN}-core"
11FILES_${PN}-spwd= " \
12 ${libdir}/python${PYTHON_MAJMIN}/lib-dynload/spwd.so \
13 ${libdir}/python${PYTHON_MAJMIN}/lib-dynload/grp.so \
14 "
Andrew Geissleracdd46d2018-08-29 06:06:42 -070015# Remove all python .py files from python recipe. Only the .pyc
16# files are required. Only do this if the openbmc-phosphor-tiny
17# distro feature is enabled
18do_install_append_openbmc-phosphor-tiny() {
Andrew Geissler37db84e2018-09-25 09:32:31 -050019 # The _sysconfigdata.py is a system configuration file generated
20 # during build time. It's used in the yocto packaging process so
21 # it is required to remain in the image.
22 find ${D}${libdir}/python${PYTHON_MAJMIN} -name \*.py ! -name _sysconfigdata.py -exec rm {} \;
Andrew Geissleracdd46d2018-08-29 06:06:42 -070023}