blob: 7eba3b0fc8540e74b6a287636546c2a5a58e07de [file] [log] [blame]
Brandon Kim236c94e2021-07-20 15:48:31 -07001SUMMARY = "Dummy image uploader for sending debug binaries"
2DESCRIPTION = "Dummy image uploader for sending debug binaries"
3PR = "r1"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
7
8inherit systemd
9
10SRC_URI += "file://config-dummy.json"
11SRC_URI += "file://dummy-verify.service"
12
13FILES_${PN} += "${datadir}/phosphor-ipmi-flash"
14
15SYSTEMD_SERVICE_${PN} += "dummy-verify.service"
16
17do_install() {
18 install -d ${D}${datadir}/phosphor-ipmi-flash
19 install -m 0644 ${WORKDIR}/config-dummy.json ${D}${datadir}/phosphor-ipmi-flash
20
21 install -d ${D}${systemd_system_unitdir}
22 install -m 0644 ${WORKDIR}/dummy-verify.service ${D}${systemd_system_unitdir}
23}