blob: 58089c0a2d8c0dbc8a55e25fd2b11ad6383539ca [file] [log] [blame]
Patrick Williams2390b1b2022-11-03 13:47:49 -05001SUMMARY = "A Gtk client and libraries for SPICE remote desktop servers."
2HOMEPAGE = "https://spice-space.org"
3LICENSE = "LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
5
6SRCREV = "74e673d7c3d9cd281d85c691fbc520107066da01"
7
8SRC_URI = "gitsm://gitlab.freedesktop.org/spice/spice-gtk.git;protocol=https;branch=master"
9
10S = "${WORKDIR}/git"
11
12DEPENDS = " \
13 ${@bb.utils.filter('DISTRO_FEATURES', 'polkit', d)} \
14 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland wayland-native wayland-protocols', '', d)} \
15 acl \
16 cyrus-sasl \
17 gstreamer1.0 \
18 gstreamer1.0-plugins-base \
19 gstreamer1.0-vaapi \
20 gtk+3 \
21 jpeg \
22 json-glib \
23 libcap-ng \
24 libepoxy \
25 libopus \
26 libusb1 \
27 lz4 \
28 pixman \
29 python3-pyparsing-native \
30 python3-six-native \
31 spice-protocol \
32 usbredir \
33 usbutils \
34 zlib \
35"
36
37RDEPENDS:${PN} = "python3-pyparsing python3-six"
38
39inherit meson pkgconfig vala gobject-introspection
40
41EXTRA_OEMESON = "-Dpie=true -Dvapi=enabled -Dintrospection=enabled"
42
43FILES:${PN} += "${datadir}"