blob: 8daf38a0ba205fb894c75d1dac7356cc8bba91be [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "F Virtual Window Manager "
2HOMEPAGE = "http://www.fvwm.org/"
3SECTION = "x11/wm"
Andrew Geissler9aee5002022-03-30 16:27:02 +00004LICENSE = "GPL-2.0-only"
Brad Bishopc342db32019-05-15 21:57:59 -04005LIC_FILES_CHKSUM = "file://COPYING;md5=f8204787357db6ea518dcc9b6cf08388"
6
7DEPENDS = " \
8 bison-native \
9 flex-native \
10 freetype-native \
11 gettext-native \
12 libxslt-native \
13 fontconfig \
14 libice \
15 libpng \
16 librsvg \
17 libsm \
18 libxau \
19 libxcb \
20 libxcursor \
21 libxdmcp \
22 libxext \
23 libxfixes \
24 libxft \
25 libxinerama \
26 libxml2 \
27 libxrender \
28 libxt \
29 virtual/libx11 \
30 xrandr \
31 zlib \
32"
33
Brad Bishopc342db32019-05-15 21:57:59 -040034SRC_URI = " \
Andrew Geissler595f6302022-01-24 19:11:47 +000035 git://github.com/fvwmorg/fvwm.git;protocol=https;branch=master \
Brad Bishopc342db32019-05-15 21:57:59 -040036 file://0001-Fix-compilation-for-disabled-gnome.patch \
37"
38
Patrick Williams2390b1b2022-11-03 13:47:49 -050039SRCREV = "7baf540e56fb1a3e91752acba872a88543529d46"
Brad Bishopc342db32019-05-15 21:57:59 -040040
41S = "${WORKDIR}/git"
42
Andrew Geissler82c905d2020-04-13 13:39:40 -050043inherit autotools gettext update-alternatives pkgconfig python3native perlnative features_check
Brad Bishopc342db32019-05-15 21:57:59 -040044# depends on virtual/libx11
45REQUIRED_DISTRO_FEATURES = "x11"
46
Patrick Williams213cb262021-08-07 19:21:33 -050047ALTERNATIVE:${PN} = "x-window-manager"
Brad Bishopc342db32019-05-15 21:57:59 -040048ALTERNATIVE_TARGET[x-window-manager] = "${bindir}/fvwm"
49ALTERNATIVE_PRIORITY[x-window-manager] = "20"
50
51EXTRA_OECONF = " \
52 --disable-bidi \
53 --disable-fontconfigtest \
54 --disable-htmldoc \
55 --disable-imlibtest \
Brad Bishopc342db32019-05-15 21:57:59 -040056 --disable-nls \
57 --disable-perllib \
58 --disable-rsvg \
59 --disable-shape \
60 --disable-sm \
61 --disable-xfttest \
62 --with-imlib-exec-prefix=/nonexistent \
63 --with-imlib-prefix=/nonexistent \
64 --without-ncurses-library \
65 --without-readline-library \
66 --without-rplay-library \
67 --without-stroke-library \
68 --without-termcap-library \
69 --without-xpm-library \
70 ac_cv_func_mkstemp=no \
71 has_safety_mkstemp=yes \
72"
73
74# show the exact commands in the log file
75EXTRA_OEMAKE = " \
76 V=1 \
77"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050078# clang treats them as errors by default now starting with 15.0+
79CFLAGS += "-Wno-error=int-conversion -Wno-error=implicit-int"
Brad Bishopc342db32019-05-15 21:57:59 -040080
Patrick Williams213cb262021-08-07 19:21:33 -050081do_install:append() {
Brad Bishopc342db32019-05-15 21:57:59 -040082 install -d -m 0755 ${D}/${sysconfdir}/xdg/fvwm
83 # You can install the config file here
84
85 install -d -m 0755 ${D}/${datadir}/fvwm
86 touch ${D}/${datadir}/fvwm/ConfigFvwmDefaults
Patrick Williams213cb262021-08-07 19:21:33 -050087 sed -i -e 's:${STAGING_BINDIR_NATIVE}/perl-native/perl:${USRBINPATH}/env perl:g' ${D}${bindir}/fvwm-*
88 sed -i -e 's:${STAGING_BINDIR_NATIVE}/perl-native/perl:${USRBINPATH}/env perl:g' ${D}${libexecdir}/fvwm/*/Fvwm*
89 sed -i -e 's:${STAGING_BINDIR_NATIVE}/python3-native/python3:${USRBINPATH}/env python3:g' ${D}${bindir}/fvwm-menu-desktop
Brad Bishopc342db32019-05-15 21:57:59 -040090}
91
92# the only needed packages (note: locale packages are automatically generated
93# as well)
94PACKAGES = " \
95 ${PN} \
Patrick Williams213cb262021-08-07 19:21:33 -050096 ${PN}-extra \
97 ${PN}-doc \
Brad Bishopc342db32019-05-15 21:57:59 -040098 ${PN}-dbg \
99"
100
101# minimal set of binaries
Patrick Williams213cb262021-08-07 19:21:33 -0500102FILES:${PN} = " \
Brad Bishopc342db32019-05-15 21:57:59 -0400103 ${bindir}/fvwm \
104 ${bindir}/fvwm-root \
105 ${datadir}/fvwm/ConfigFvwmDefaults \
106"
107
Patrick Williams213cb262021-08-07 19:21:33 -0500108FILES:${PN}-extra = " \
109 ${bindir} \
110 ${libexecdir} \
111 ${sysconfdir}/xdg/fvwm \
112"
113FILES:${PN}-doc = " \
114 ${mandir} \
115 ${datadir}/fvwm \
116"
117RDEPENDS:${PN} = " \
Brad Bishopc342db32019-05-15 21:57:59 -0400118 xuser-account \
119"
Patrick Williams213cb262021-08-07 19:21:33 -0500120RDEPENDS:${PN}-extra += "\
121 perl \
122 python3-core \
Brad Bishopc342db32019-05-15 21:57:59 -0400123"