blob: f9e153016141d6cea686e84fed5b1848aaae4580 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "The iniParser library is a simple C library offering INI file parsing services (both reading and writing)."
2SECTION = "libs"
3HOMEPAGE = "https://github.com/ndevilla/iniparser"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e02baf71c76e0650e667d7da133379ac"
6
7DEPENDS = "doxygen-native"
8
Andrew Geissler9aee5002022-03-30 16:27:02 +00009PV .= "+git${SRCPV}"
10
Andrew Geissler595f6302022-01-24 19:11:47 +000011SRC_URI = "git://github.com/ndevilla/iniparser.git;protocol=https;branch=master \
Andrew Geissler9aee5002022-03-30 16:27:02 +000012 file://0001-iniparser.pc-Make-libpath-a-variable.patch \
Brad Bishop26bdd442019-08-16 17:08:17 -040013 file://Add-CMake-support.patch"
14
Andrew Geissler9aee5002022-03-30 16:27:02 +000015SRCREV= "deb85ad4936d4ca32cc2260ce43323d47936410d"
Brad Bishop26bdd442019-08-16 17:08:17 -040016
17S = "${WORKDIR}/git"
18
19inherit cmake
Andrew Geissler9aee5002022-03-30 16:27:02 +000020
21do_install:append() {
22 install -Dm 0644 ${S}/iniparser.pc ${D}${libdir}/pkgconfig/iniparser.pc
23 sed -i -e 's,@baselib@,${baselib},g' ${D}${libdir}/pkgconfig/iniparser.pc
24}
Patrick Williams2390b1b2022-11-03 13:47:49 -050025
26BBCLASSEXTEND += "native"