blob: 238c988850bb07b804e48e63f1124d4577dcbcbe [file] [log] [blame]
Patrick Williams2390b1b2022-11-03 13:47:49 -05001SUMMARY = "Low-Level Interface to bzip2 compression library"
Andrew Geissler595f6302022-01-24 19:11:47 +00002DESCRIPTION = ""Compress::Raw::Bzip2" provides an interface to the in-memory \
3compression/uncompression functions from the bzip2 compression library."
Patrick Williams2390b1b2022-11-03 13:47:49 -05004HOMEPAGE = "https://metacpan.org/release/Compress-Raw-Bzip2"
Andrew Geissler595f6302022-01-24 19:11:47 +00005SECTION = "libs"
Andrew Geissler9aee5002022-03-30 16:27:02 +00006LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
Andrew Geissler595f6302022-01-24 19:11:47 +00007
Patrick Williams2390b1b2022-11-03 13:47:49 -05008LIC_FILES_CHKSUM = "file://README;beginline=8;endline=10;md5=33084b7f607ba5d38a64b22f8e332f87"
Andrew Geissler595f6302022-01-24 19:11:47 +00009
Patrick Williams2390b1b2022-11-03 13:47:49 -050010SRC_URI = "${CPAN_MIRROR}/authors/id/P/PM/PMQS/Compress-Raw-Bzip2-${PV}.tar.gz"
Andrew Geissler595f6302022-01-24 19:11:47 +000011
12SRC_URI[md5sum] = "4fdb7ea5071e4b774c52c37331386355"
13SRC_URI[sha256sum] = "a564e7634eca7740c5487d01effe1461e9e51b8909e69b3d8f5be98997958cbe"
14
15DEPENDS += "bzip2"
16
17S = "${WORKDIR}/Compress-Raw-Bzip2-${PV}"
18
19inherit cpan
20
21export BUILD_BZIP2="0"
22export BZIP2_INCLUDE="-I${STAGING_DIR_HOST}${includedir}"
23
24do_compile() {
25 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
26 cpan_do_compile
27}
28
29BBCLASSEXTEND = "native"