blob: dcd5badab97e70f0b0a9d42dc5c2abd91d6c409c [file] [log] [blame]
Patrick Williams2390b1b2022-11-03 13:47:49 -05001SUMMARY = "Perl interface to the zlib compression library."
2DESCRIPTION = "The Compress::Raw::Zlib module provides a Perl interface \
3to the zlib compression library (see 'AUTHOR' for details about where to \
4get zlib)."
5HOMEPAGE = "https://metacpan.org/release/Compress-Raw-Zlib"
6SECTION = "libs"
7LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
8
9LIC_FILES_CHKSUM = "file://README;beginline=8;endline=17;md5=603fa463887aed6bb3f6f2a999aca775"
10
11SRC_URI = "${CPAN_MIRROR}/authors/id/P/PM/PMQS/Compress-Raw-Zlib-${PV}.tar.gz"
12
13SRC_URI[md5sum] = "4144ecdd901231553447998cf8035e4a"
14SRC_URI[sha256sum] = "cd4cba20c159a7748b8bc91278524a7da70573d9531fde62298609a5f1c65912"
15
16DEPENDS += "zlib"
17
18S = "${WORKDIR}/Compress-Raw-Zlib-${PV}"
19
20inherit cpan
21
22export BUILD_ZLIB="0"
23
24do_compile() {
25 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
26 cpan_do_compile
27}
28
29BBCLASSEXTEND = "native"