blob: ea120b824671f5eb5ff20fd585a961d6a34e5410 [file] [log] [blame]
Patrick Williams2390b1b2022-11-03 13:47:49 -05001SUMMARY = "Perl interface to allow reading and writing of compressed data."
2DESCRIPTION = "This distribution provides a Perl interface to allow reading \
3and writing of compressed data created with the zlib and bzip2. \
4\
5IO-Compress supports reading and writing of the following compressed data \
6formats \
7 * bzip2 \
8 * RFC 1950 \
9 * RFC 1951 \
10 * RFC 1952 (i.e. gzip) \
11 * zip \
12"
13HOMEPAGE = "https://metacpan.org/release/IO-Compress"
Andrew Geissler9aee5002022-03-30 16:27:02 +000014SECTION = "libs"
15LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
16
Patrick Williams2390b1b2022-11-03 13:47:49 -050017LIC_FILES_CHKSUM = "file://README;beginline=8;endline=10;md5=36e282c4a4078cf2650d656cdda23210"
Andrew Geissler9aee5002022-03-30 16:27:02 +000018
Patrick Williams2390b1b2022-11-03 13:47:49 -050019SRC_URI = "${CPAN_MIRROR}/authors/id/P/PM/PMQS/IO-Compress-${PV}.tar.gz"
Andrew Geissler9aee5002022-03-30 16:27:02 +000020
21SRC_URI[md5sum] = "18ad197cad5ca87bc3a7d2538998e017"
22SRC_URI[sha256sum] = "9d219fd5df4b490b5d2f847921e3cb1c3392758fa0bae9b05a8992b3620ba572"
Andrew Geissler9aee5002022-03-30 16:27:02 +000023
24S = "${WORKDIR}/IO-Compress-${PV}"
25
26inherit cpan
27
Patrick Williams2390b1b2022-11-03 13:47:49 -050028RDEPENDS:${PN} += "\
29 perl-module-bytes \
30 perl-module-cwd \
31 perl-module-encode \
32 perl-module-file-glob \
33 perl-module-file-spec \
34 perl-module-posix \
35 perl-module-scalar-util \
36 perl-module-utf8 \
37 libcompress-raw-bzip2-perl \
38 libcompress-raw-zlib-perl \
39"
40
Andrew Geissler9aee5002022-03-30 16:27:02 +000041BBCLASSEXTEND = "native"