blob: 14ad459c1b1cd52b9f190b7086bbce0f3118cdff [file] [log] [blame]
Patrick Williams2390b1b2022-11-03 13:47:49 -05001SUMMARY = "Provides cryptographic recipes and primitives to python developers"
2HOMEPAGE = "https://cryptography.io/"
3SECTION = "devel/python"
4LICENSE = "( Apache-2.0 | BSD-3-Clause ) & PSF-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=bf405a8056a6647e7d077b0e7bc36aba \
6 file://LICENSE.APACHE;md5=4e168cce331e5c827d4c2b68a6200e1b \
7 file://LICENSE.BSD;md5=5ae30ba4123bc4f2fa49aa0b0dce887b \
8 file://LICENSE.PSF;md5=43c37d21e1dbad10cddcd150ba2c0595 \
9 "
10LDSHARED += "-pthread"
11
12SRC_URI[sha256sum] = "bfbe6ee19615b07a98b1d2287d6a6073f734735b49ee45b11324d85efc4d5cbd"
13
14SRC_URI += "\
15 file://0002-Cargo.toml-edition-2018-2021.patch \
16 file://0001-pyproject.toml-remove-benchmark-disable-option.patch \
17 file://check-memfree.py \
18 file://run-ptest \
19"
20
21require ${BPN}-crates.inc
22
23inherit pypi python_setuptools3_rust cargo-update-recipe-crates
24
25DEPENDS += " \
26 ${PYTHON_PN}-cffi-native \
27"
28
29RDEPENDS:${PN} += " \
30 ${PYTHON_PN}-cffi \
31"
32
33RDEPENDS:${PN}:append:class-target = " \
34 ${PYTHON_PN}-numbers \
35 ${PYTHON_PN}-threading \
36"
37
38RDEPENDS:${PN}-ptest += " \
39 ${PYTHON_PN}-bcrypt \
40 ${PYTHON_PN}-cryptography-vectors (= ${PV}) \
41 ${PYTHON_PN}-hypothesis \
42 ${PYTHON_PN}-iso8601 \
43 ${PYTHON_PN}-pretend \
44 ${PYTHON_PN}-psutil \
45 ${PYTHON_PN}-pytest \
46 ${PYTHON_PN}-pytest-subtests \
47 ${PYTHON_PN}-pytz \
48 ${PYTHON_PN}-tomli \
49"
50
51inherit ptest
52
53do_install_ptest() {
54 install -D ${WORKDIR}/check-memfree.py ${D}${PTEST_PATH}/
55 install -d ${D}${PTEST_PATH}/tests
56 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
57 # remove test_x509.py as it needs benchmark and we don't
58 # want to introduce the benchmark dependency
59 rm -rf ${D}${PTEST_PATH}/tests/bench/test_x509.py
60 install -d ${D}${PTEST_PATH}/tests/hazmat
61 cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/
62 cp -r ${S}/pyproject.toml ${D}${PTEST_PATH}/
63}
64
65FILES:${PN}-ptest += " \
66 ${PTEST_PATH}/check-memfree.py \
67"
68FILES:${PN}-dbg += " \
69 ${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}/hazmat/bindings/.debug \
70"
71
72BBCLASSEXTEND = "native nativesdk"