blob: e0cf64c70ef11da13377f2515756781af3348bdf [file] [log] [blame]
Patrick Williams2390b1b2022-11-03 13:47:49 -05001SUMMARY = "Python bindings for the DBus inter-process communication system"
2SECTION = "devel/python"
3HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=97f58951300aa52a9f9e3a62bd5c846c"
6DEPENDS = "expat dbus glib-2.0 virtual/libintl"
7
8SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz"
9
10SRC_URI[sha256sum] = "ad67819308618b5069537be237f8e68ca1c7fcc95ee4a121fe6845b1418248f8"
11
12S = "${WORKDIR}/dbus-python-${PV}"
13
14inherit setuptools3-base meson pkgconfig
15
16# requires dbus-run-session
17EXTRA_OEMESON += "-Dtests=false"
18
19RDEPENDS:${PN} = "python3-io python3-logging python3-stringold python3-threading python3-xml"
20
21FILES:${PN}-dev += "${libdir}/pkgconfig"
22
23BBCLASSEXTEND = "native nativesdk"