blob: fce3aea8977708aeb51170f2999ee9f5e84cd423 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001DESCRIPTION = "More routines for operating on iterables, beyond itertools"
2HOMEPAGE = "https://github.com/erikrose/more-itertools"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3396ea30f9d21389d7857719816f83b5"
5
Patrick Williams2390b1b2022-11-03 13:47:49 -05006SRC_URI[sha256sum] = "5a6257e40878ef0520b1803990e3e22303a41b5714006c32a3fd8304b26ea1ab"
Patrick Williams92b42cb2022-09-03 06:53:57 -05007
8inherit pypi python_flit_core ptest
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
14RDEPENDS:${PN} += " \
15 ${PYTHON_PN}-asyncio \
16 "
17
18RDEPENDS:${PN}-ptest += " \
19 ${PYTHON_PN}-pytest \
20 "
21
22do_install_ptest() {
23 install -d ${D}${PTEST_PATH}/tests
24 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
25}
26
27BBCLASSEXTEND = "native nativesdk"