blob: 708201043b53a68a49127383358aa4570757aae0 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "WPE's backend based on a freedesktop.org stack."
2HOMEPAGE = "https://github.com/Igalia/WPEBackend-fdo"
3BUGTRACKER = "https://github.com/Igalia/WPEBackend-fdo/issues"
4
5LICENSE = "BSD-2-Clause"
6LIC_FILES_CHKSUM = "file://COPYING;md5=1f62cef2e3645e3e74eb05fd389d7a66"
7DEPENDS = "glib-2.0 libxkbcommon wayland virtual/egl libwpe libepoxy"
8
9DEPENDS:append:class-target = " wayland-native"
10
11inherit meson features_check pkgconfig
12
13REQUIRED_DISTRO_FEATURES = "opengl"
14
15SRC_URI = "https://wpewebkit.org/releases/${BPN}-${PV}.tar.xz"
Patrick Williams2390b1b2022-11-03 13:47:49 -050016SRC_URI[sha256sum] = "e75b0cb2c7145448416e8696013d8883f675c66c11ed750e06865efec5809155"
Patrick Williams92b42cb2022-09-03 06:53:57 -050017
18# Especially helps compiling with clang which enable this as error when
19# using c++11
20CXXFLAGS += "-Wno-c++11-narrowing"
21
22# This is a tweak of upstream-version-is-even needed because
23# ipstream directory contains tarballs for other components as well.
24UPSTREAM_CHECK_REGEX = "wpebackend-fdo-(?P<pver>\d+\.(\d*[02468])+(\.\d+)+)\.tar"