blob: 60fbea5504a929e24df961c67bfc5c30c6053d84 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "An HTTP library implementation in C"
2DESCRIPTION = "libsoup is an HTTP client/server library for GNOME. It uses GObjects \
3and the glib main loop, to integrate well with GNOME applications."
4HOMEPAGE = "https://wiki.gnome.org/Projects/libsoup"
5BUGTRACKER = "https://bugzilla.gnome.org/"
6SECTION = "x11/gnome/libs"
7LICENSE = "LGPL-2.0-only"
8LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
9
10DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 libpsl nghttp2"
11
12SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
13
14SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz"
Patrick Williams2390b1b2022-11-03 13:47:49 -050015SRC_URI[sha256sum] = "2832370698ca8f9fbf174c345b73d89b60561103a626c2df70726b0707f79bd3"
Andrew Geissler9aee5002022-03-30 16:27:02 +000016
17PROVIDES = "libsoup-3.0"
18CVE_PRODUCT = "libsoup"
19
20S = "${WORKDIR}/libsoup-${PV}"
21
Patrick Williams2390b1b2022-11-03 13:47:49 -050022inherit meson gettext pkgconfig upstream-version-is-even gobject-introspection gi-docgen
Andrew Geissler9aee5002022-03-30 16:27:02 +000023
24GIR_MESON_ENABLE_FLAG = 'enabled'
25GIR_MESON_DISABLE_FLAG = 'disabled'
26
27# libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Disable by default.
28PACKAGECONFIG ??= ""
29PACKAGECONFIG[gssapi] = "-Dgssapi=enabled,-Dgssapi=disabled,krb5"
30
31EXTRA_OEMESON:append = " -Dvapi=disabled -Dtls_check=false"
32
Patrick Williams2390b1b2022-11-03 13:47:49 -050033GIDOCGEN_MESON_OPTION = 'docs'
34GIDOCGEN_MESON_ENABLE_FLAG = 'enabled'
35GIDOCGEN_MESON_DISABLE_FLAG = 'disabled'
Andrew Geissler9aee5002022-03-30 16:27:02 +000036
37# When built without gnome support, libsoup will contain only one shared lib
38# and will therefore become subject to renaming by debian.bbclass. Prevent
39# renaming in order to keep the package name consistent regardless of whether
40# gnome support is enabled or disabled.
41DEBIAN_NOAUTONAME:${PN} = "1"
42
43# glib-networking is needed for SSL, proxies, etc.
44RRECOMMENDS:${PN} = "glib-networking"
45
46BBCLASSEXTEND = "native nativesdk"