blob: bd6dcef4e3c9b6d4f4bc8f01cb9f2216fb98b6f4 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Memory Efficient Serialization Library"
2HOMEPAGE = "https://github.com/google/flatbuffers"
3SECTION = "console/tools"
4LICENSE = "Apache-2.0"
5
6PACKAGE_BEFORE_PN = "${PN}-compiler"
7
8RDEPENDS_${PN}-compiler = "${PN}"
9RDEPENDS_${PN}-dev += "${PN}-compiler"
10
11LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a873c5645c184d51e0f9b34e1d7cf559"
12
Brad Bishop23eaf032019-11-20 05:15:02 -050013SRCREV = "9e7e8cbe9f675123dd41b7c62868acad39188cae"
Brad Bishop19323692019-04-05 15:28:33 -040014
Brad Bishop23eaf032019-11-20 05:15:02 -050015SRC_URI = "git://github.com/google/flatbuffers.git \
16 file://0001-Add-detection-of-strtoull_l-function.patch \
17 "
Brad Bishop19323692019-04-05 15:28:33 -040018
19# Make sure C++11 is used, required for example for GCC 4.9
20CXXFLAGS += "-std=c++11"
21BUILD_CXXFLAGS += "-std=c++11"
22
23# BUILD_TYPE=Release is required, otherwise flatc is not installed
24EXTRA_OECMAKE += "\
25 -DCMAKE_BUILD_TYPE=Release \
26 -DFLATBUFFERS_BUILD_TESTS=OFF \
27 -DFLATBUFFERS_BUILD_SHAREDLIB=ON \
28"
29
30inherit cmake
31
32S = "${WORKDIR}/git"
33
34FILES_${PN}-compiler = "${bindir}"
35
36BBCLASSEXTEND = "native nativesdk"