blob: bf9eb0a1cc7450a246b7f784f8d62803f87a656f [file] [log] [blame]
Brad Bishop23eaf032019-11-20 05:15:02 -05001SUMMARY = "Library to process JSON-RPC requests"
2HOMEPAGE = "https://github.com/bcb/jsonrpcserver"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=c89120516900f96f4c60d35fdc4c3f15"
5
6SRC_URI[md5sum] = "d41e9f6b310cb29b0d8f213ff9d57567"
7SRC_URI[sha256sum] = "240c517f49b0fdd3bfa428c9a7cc581126a0c43eca60d29762da124017d9d9f4"
8
9inherit pypi setuptools3
10
11RDEPENDS_${PN} += "\
12 python3-apply-defaults \
13 python3-asyncio \
14 python3-core \
15 python3-json \
16 python3-jsonschema \
17 python3-logging \
18 python3-netclient \
19 python3-pkgutil \
20 python3-typing \
21"
22
23BBCLASSEXTEND = "native nativesdk"