blob: 80fe94555253b8b55e28eabbdf7aa623eed669c7 [file] [log] [blame]
Andrew Geissler2ee498a2020-05-29 15:52:06 -05001DESCRIPTION = "XMODEM protocol implementation"
2
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
5
Patrick Williams520786c2023-06-25 16:20:36 -05006SRC_URI[sha256sum] = "2f1068aa8676f0d1d112498b5786c4f8ea4f89d8f25d07d3a0f293cd21db1c35"
Andrew Geissler2ee498a2020-05-29 15:52:06 -05007
8inherit pypi setuptools3
9
Andrew Geissler9aee5002022-03-30 16:27:02 +000010do_install:append() {
11 install -d ${D}${docdir}/${PN}
12 mv ${D}/usr/doc/* ${D}${docdir}/${PN}/
13 rmdir ${D}/usr/doc
14}
15
Patrick Williams213cb262021-08-07 19:21:33 -050016RDEPENDS:${PN} += " \
Andrew Geissler2ee498a2020-05-29 15:52:06 -050017 ${PYTHON_PN}-logging \
18"
Andrew Geissler2ee498a2020-05-29 15:52:06 -050019BBCLASSEXTEND = "native nativesdk"