blob: 8a92d7fd12884c0436b7fcfbdad57d47cf76f2f3 [file] [log] [blame]
Vijay Khemkae810c502019-10-30 10:31:48 -07001SUMMARY = "Chassis Power Control service for Intel based platforms"
2DESCRIPTION = "Chassis Power Control service for Intel based platforms"
3
4SRC_URI = "git://github.com/openbmc/x86-power-control.git;protocol=ssh"
Andrew Geissler24fa6042020-01-30 12:51:33 +00005SRCREV = "89f613129b112d7b4595410e99eac0db4e92bb8e"
Vijay Khemkae810c502019-10-30 10:31:48 -07006
7PV = "1.0+git${SRCPV}"
8
9S = "${WORKDIR}/git"
10
11LICENSE = "Apache-2.0"
12LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
13
14inherit cmake systemd
15
16SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Chassis.Control.Power.service"
17
18DEPENDS += " \
19 boost \
20 i2c-tools \
21 libgpiod \
22 sdbusplus \
23 phosphor-logging \
24 "