Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | # Copyright (C) 2020 Khem Raj <raj.khem@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | SUMMARY = "Kronosnet, often referred to as knet, is a network abstraction layer \ |
| 5 | designed for High Availability use cases, where redundancy, security, \ |
| 6 | fault tolerance and fast fail-over are the core requirements of your application." |
| 7 | HOMEPAGE = "https://kronosnet.org/" |
| 8 | LICENSE = "GPL-2.0-or-later & LGPL-2.1-only" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING.applications;md5=751419260aa954499f7abaabaa882bbe \ |
| 10 | file://COPYING.libraries;md5=2d5025d4aa3495befef8f17206a5b0a1" |
| 11 | SECTION = "libs" |
| 12 | DEPENDS = "doxygen-native libqb-native libxml2-native bzip2 libqb libxml2 libnl lksctp-tools lz4 lzo openssl nss xz zlib zstd" |
| 13 | |
| 14 | SRCREV = "f8f80fd7f9b85f2626d2c6452612962ad8efca9e" |
| 15 | SRC_URI = "git://github.com/kronosnet/kronosnet;protocol=https;branch=stable1 \ |
| 16 | file://0001-links.c-Fix-build-with-gcc-12.patch \ |
| 17 | " |
| 18 | |
| 19 | UPSTREAM_CHECK_URI = "https://github.com/kronosnet/kronosnet/releases" |
| 20 | |
| 21 | inherit autotools pkgconfig |
| 22 | |
| 23 | S = "${WORKDIR}/git" |
| 24 | |
| 25 | # libknet/transport_udp.c:326:48: error: comparison of integers of different signs: 'unsigned long' and 'int' [-Werror,-Wsign-compare] |
| 26 | # for (cmsg = CMSG_FIRSTHDR(&msg);cmsg; cmsg = CMSG_NXTHDR(&msg, cmsg)) { |
| 27 | # ^~~~~~~~~~~~~~~~~~~~~~~ |
| 28 | CFLAGS:append:toolchain-clang = " -Wno-sign-compare" |
| 29 | |
| 30 | PACKAGECONFIG[man] = "enable_man="yes", --disable-man, " |
| 31 | |
| 32 | PACKAGECONFIG:remove = "man" |