blob: 5c17dfc558b3fec8d42949eefa9200fd69df967b [file] [log] [blame]
Jason M. Bills267243e2018-10-05 09:17:31 -07001SUMMARY = "Intel OEM IPMI commands"
2DESCRIPTION = "Intel OEM IPMI commands"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=a6a4edad4aed50f39a66d098d74b265b"
6
7SRC_URI = "git://github.com/openbmc/intel-ipmi-oem"
8SRCREV = "6479604111b8198592c1054a3bad751f3b80a689"
9
10S = "${WORKDIR}/git"
11PV = "0.1+git${SRCPV}"
12
13DEPENDS = "boost phosphor-ipmi-host systemd microsoft-gsl"
14
15inherit cmake obmc-phosphor-ipmiprovider-symlink
16
17EXTRA_OECMAKE="-DENABLE_TEST=0 -DYOCTO=1"
18
19LIBRARY_NAMES = "libsensorcommands.so"
20LIBRARY_NAMES += "libzstoragecommands.so"
21LIBRARY_NAMES += "liboemcmds.so"
22
23HOSTIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
24NETIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
25
26FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
27FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
28FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
29FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}"