blob: 6c44ef83801c0acced65149e4db36e89baca182b [file] [log] [blame]
Brandon Kim26764512022-06-22 16:18:54 -07001SUMMARY = "BIOS BMC SMM Error Logger"
2DESCRIPTION = "Allows BIOS in SMM to log errors to the BMC"
3PR = "r1"
4PV = "0.1+git${SRCPV}"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
7inherit meson pkgconfig systemd
8
9DEPENDS += " \
10 boost \
11 stdplus \
12 systemd \
13 nlohmann-json \
14 "
15
16S = "${WORKDIR}/git"
17
18SRC_URI = "git://github.com/openbmc/bios-bmc-smm-error-logger;branch=main;protocol=https"
19SRCREV = "1a3dc60db5f8764ea8b97fda5973ccbb894596df"
20
21SYSTEMD_SERVICE:${PN} += "xyz.openbmc_project.bios_bmc_smm_error_logger.service"
22