blob: 37f512a73c6c595e6a7f7c5cd8c5d0769ad1a7b5 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "GTK+ applet for NetworkManager"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
4
Brad Bishopc8f47122019-06-24 09:36:18 -04005DEPENDS = "gtk+3 libnotify libsecret networkmanager \
Brad Bishop26bdd442019-08-16 17:08:17 -04006 libgnome-keyring iso-codes nss \
Brad Bishop19323692019-04-05 15:28:33 -04007 intltool-native \
8"
9
10GNOMEBASEBUILDCLASS = "autotools-brokensep"
Brad Bishop26bdd442019-08-16 17:08:17 -040011inherit distro_features_check gnomebase gsettings gtk-icon-cache gobject-introspection gettext
Brad Bishop19323692019-04-05 15:28:33 -040012
13REQUIRED_DISTRO_FEATURES = "x11"
14
Brad Bishop26bdd442019-08-16 17:08:17 -040015SRC_URI[archive.md5sum] = "e0373f4c0d0637716e6e385799a9080f"
16SRC_URI[archive.sha256sum] = "ebef1c1050ff6d94cad060e8d259f2a88ae159cf83ca75cb71d9f76867877eed"
Brad Bishop19323692019-04-05 15:28:33 -040017
18PACKAGECONFIG[modemmanager] = "--with-wwan,--without-wwan,modemmanager"
19PACKAGECONFIG[mobile-provider-info] = "--enable-mobile-broadband-provider-info,--disable-mobile-broadband-provider-info,mobile-broadband-provider-info,mobile-broadband-provider-info"
20PACKAGECONFIG ??= ""
21
22EXTRA_OECONF = " \
23 --without-selinux \
24"
25
Brad Bishop19323692019-04-05 15:28:33 -040026# gobject-introspection related
27GI_DATA_ENABLED_libc-musl = "False"
28
29do_compile_prepend() {
Brad Bishopc8f47122019-06-24 09:36:18 -040030 export GIR_EXTRA_LIBS_PATH="${B}/src/libnma/.libs"
Brad Bishop19323692019-04-05 15:28:33 -040031}
32
33RDEPENDS_${PN} =+ "networkmanager"
34
35FILES_${PN} += " \
36 ${datadir}/nm-applet/ \
Brad Bishop19323692019-04-05 15:28:33 -040037 ${datadir}/libnma/wifi.ui \
38 ${datadir}/metainfo \
39"
40
41# musl builds generate gir files which otherwise go un-packaged
42FILES_${PN}-dev += " \
43 ${datadir}/gir-1.0 \
44"