blob: ef6ea7946ae76c266dc2a2da1cb22f7e3e6f184b [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SECTION = "x11/wm"
2SUMMARY = "Metacity is the boring window manager for the adult in you"
3LICENSE = "GPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b4cce53560b8e619ffa7c830fb8761aa \
5 file://src/include/main.h;endline=24;md5=72148ede07a6dadd01de6a882d20a9ad"
6
7PE = "1"
8
9DEPENDS = "gsettings-desktop-schemas startup-notification \
10 gnome-doc-utils gdk-pixbuf-native \
11 gtk+3 glib-2.0 libcanberra libgtop intltool-native"
12
13inherit autotools gettext gnomebase distro_features_check
14# depends on startup-notification which depends on virtual/libx11
15REQUIRED_DISTRO_FEATURES = "x11"
16
17SRC_URI = "git://github.com/GNOME/metacity.git;branch=master \
18 file://0001-drop-zenity-detection.patch \
19"
20
21S = "${WORKDIR}/git"
Brad Bishop26bdd442019-08-16 17:08:17 -040022SRCREV = "bf1bfbadf47eff97703df17e95b15168e2034222"
Brad Bishop19323692019-04-05 15:28:33 -040023
24EXTRA_OECONF += "--disable-xinerama"
25
26PACKAGECONFIG ?= ""
27
28# enable as neccessary until new warnings are dealt with
29PACKAGECONFIG[werror] = "--enable-Werror,--disable-Werror,,"
30
31do_configure_prepend() {
32 cd ${S}
33 aclocal --install || exit 1
34 autoreconf --verbose --force --install -Wno-portability || exit 1
35 cd -
36
37}
38
39FILES_${PN} += "${datadir}/themes ${datadir}/gnome-control-center ${datadir}/gnome"
40RDEPENDS_${PN} += "gsettings-desktop-schemas"
41