blob: 6088ef19542666d4cbd96a1c1400e637557886c8 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "Resource discovery and announcement over SSDP"
2DESCRIPTION = "GSSDP implements resource discovery and announcement over SSDP (Simpe Service Discovery Protocol)."
3LICENSE = "LGPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
5DEPENDS = "glib-2.0 libsoup-2.4"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05006
7SRC_URI = "${GNOME_MIRROR}/${BPN}/1.0/${BPN}-${PV}.tar.xz"
8SRC_URI[md5sum] = "b30c9a406853c6a3a012d151d6e7ad2c"
9SRC_URI[sha256sum] = "a1e17c09c7e1a185b0bd84fd6ff3794045a3cd729b707c23e422ff66471535dc"
Brad Bishop26bdd442019-08-16 17:08:17 -040010
11inherit autotools pkgconfig gobject-introspection vala gtk-doc
12
13# Copy vapigen.m4 so that it doesn't get removed by vala class
14# (normally this would be the right thing to do, but in gssdp the vapigen.m4 has only a custom macro)
15do_configure_prepend() {
16 cp -f ${S}/m4/vapigen.m4 ${S}/m4/vapigen-custom.m4 || true
17}
18
19PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk', '', d)}"
20PACKAGECONFIG[gtk] = "--with-gtk,--without-gtk,gtk+3"
21
22PACKAGES =+ "gssdp-tools"
23
24FILES_gssdp-tools = "${bindir}/gssdp* ${datadir}/gssdp/*.glade"