blob: 0adc721d8d02ea2424fbb084d187964e5a3b3bed [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "A UPnP AV media server and renderer"
2DESCRIPTION = "Rygel is a home media solution (UPnP AV MediaServer) that \
3allow you to easily share audio, video and pictures to other devices. \
4Additionally, media player software may use Rygel to become a MediaRenderer \
5that may be controlled remotely by a UPnP or DLNA Controller."
6HOMEPAGE = "http://live.gnome.org/Rygel"
7
8LICENSE = "LGPL-2.1"
9LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
10
11DEPENDS = "libxml2 glib-2.0 gssdp gupnp gupnp-av gupnp-dlna gstreamer1.0 gstreamer1.0-plugins-base libgee libsoup-2.4 libmediaart-2.0 libunistring sqlite3 intltool-native"
12RDEPENDS_${PN} = "gstreamer1.0-plugins-base-playback shared-mime-info"
13RRECOMMENDS_${PN} = "rygel-plugin-media-export"
14
Brad Bishop19323692019-04-05 15:28:33 -040015SRC_URI[archive.md5sum] = "f897167ad82e2e741582f2c393a76843"
16SRC_URI[archive.sha256sum] = "dfd3d885da3ac383ba0cfbf119995f4a0c2bca2cc8f8cfcd3df10cfec8f35cd7"
17
18inherit gnomebase vala gobject-introspection gettext systemd
19
20EXTRA_OECONF = "--disable-tracker-plugin --with-media-engine=gstreamer"
21
22PACKAGECONFIG ?= "external mpris ruih media-export gst-launch"
23
24PACKAGECONFIG_append = "${@bb.utils.contains("DISTRO_FEATURES", "x11", " gtk+3", "", d)}"
25
26PACKAGECONFIG[external] = "--enable-external-plugin,--disable-external-plugin"
27PACKAGECONFIG[mpris] = "--enable-mpris-plugin,--disable-mpris-plugin"
28PACKAGECONFIG[ruih] = "--enable-ruih-plugin,--disable-ruih-plugin"
29PACKAGECONFIG[media-export] = "--enable-media-export-plugin,--disable-media-export-plugin"
30PACKAGECONFIG[gst-launch] = "--enable-gst-launch-plugin,--disable-gst-launch-plugin"
31PACKAGECONFIG[gtk+3] = ",--without-ui,gtk+3"
32PACKAGECONFIG[lms] = "--enable-lms-plugin,--disable-lms-plugin"
33
34LIBV = "2.6"
35
36do_install_append() {
37 # Remove .la files for loadable modules
38 rm -f ${D}/${libdir}/rygel-${LIBV}/engines/*.la
39 rm -f ${D}/${libdir}/rygel-${LIBV}/plugins/*.la
40 if [ -e ${D}${libdir}/systemd/user/rygel.service ]; then
41 mkdir -p ${D}${systemd_unitdir}/system
42 mv ${D}${libdir}/systemd/user/rygel.service ${D}${systemd_unitdir}/system
43 rmdir ${D}${libdir}/systemd/user ${D}${libdir}/systemd
44 fi
45}
46
47FILES_${PN} += "${libdir}/rygel-${LIBV}/engines ${datadir}/dbus-1 ${datadir}/icons"
48FILES_${PN}-dbg += "${libdir}/rygel-${LIBV}/engines/.debug ${libdir}/rygel-${LIBV}/plugins/.debug"
49
50PACKAGES += "${PN}-meta"
51ALLOW_EMPTY_${PN}-meta = "1"
52
53PACKAGES_DYNAMIC = "${PN}-plugin-*"
54
55SYSTEMD_SERVICE_${PN} = "rygel.service"
56
57python populate_packages_prepend () {
58 rygel_libdir = d.expand('${libdir}/rygel-${LIBV}')
59 postinst = d.getVar('plugin_postinst')
60 pkgs = []
61
62 pkgs += do_split_packages(d, oe.path.join(rygel_libdir, "plugins"), 'librygel-(.*)\.so$', d.expand('${PN}-plugin-%s'), 'Rygel plugin for %s', postinst=postinst, extra_depends=d.expand('${PN}'))
63 pkgs += do_split_packages(d, oe.path.join(rygel_libdir, "plugins"), '(.*)\.plugin$', d.expand('${PN}-plugin-%s'), 'Rygel plugin for %s', postinst=postinst, extra_depends=d.expand('${PN}'))
64
65 metapkg = d.getVar('PN') + '-meta'
66 d.setVar('RDEPENDS_' + metapkg, ' '.join(pkgs))
67}