blob: ba1ef6b1fc427534d66b15ab7b06dd799bba8edd [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001require ${BPN}.inc
2
3DEPENDS = "${BPN}-native alsa-lib ncurses glib-2.0"
4
5SRC_URI += " \
6 file://0001-Do-not-build-gentables-helper-we-have-to-use-native-.patch \
7 file://0002-fluid_synth_nwrite_float-Allow-zero-pointer-for-left.patch \
8 file://0003-Use-ARM-NEON-accelaration-for-float-multithreaded-se.patch \
9"
10
11EXTRA_OECMAKE = "-Denable-floats=ON -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')}"
12
13do_configure_append() {
14 make_tables.exe ${B}/
15}
16
17PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio', d)}"
18PACKAGECONFIG[sndfile] = "-Denable-libsndfile=ON,-Denable-libsndfile=OFF,libsndfile1"
19PACKAGECONFIG[jack] = "-Denable-jack=ON,-Denable-jack=OFF,jack"
20PACKAGECONFIG[pulseaudio] = "-Denable-pulseaudio=ON,-Denable-pulseaudio=OFF,pulseaudio"
21PACKAGECONFIG[portaudio] = "-Denable-portaudio=ON,-Denable-portaudio=OFF,portaudio-v19"
22PACKAGECONFIG[profiling] = "-Denable-profiling=ON,-Denable-profiling=OFF"
Brad Bishop26bdd442019-08-16 17:08:17 -040023PACKAGECONFIG[readline] = "-Denable-readline=ON,-Denable-readline=OFF,readline"